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The Durham icemcfd Tutorial

Introduction

This provides a short step by step guide to meshing an aerofoil using the icemcfd package.  The aim 
being to introduce you the important features of the program in the shortest possible space of time. 
The mesh that this tutorial produces will require further work to be used as a basis for serious 
calculations but this tutorial contains all the information that you need to do this.  

icemcfd is available on the University GNU/Linux service called vega.  Once you have logged into 
vega you can start it from the command line using the command icemcfd.  

The initial screen looks something like:

As well as the conventional display area and menus there are three areas of note:

● Tabs: These provide access to broad categories of tools which enable the meshing to take 
place.

● Tools: This area in the bottom left is where the tools are actually operated from

● Tree: In this area a hierarchical list of points, lines and so on will be built up as you work 
with the software.  

icemcfd is a powerful package but does have something of a learning curve, so if something doesn't 
work the first time review the steps you took carefully and try again.  
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Figure 1: The icemcfd screen.
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Importing the Geometry

● Start icemcfd

● Obtain the NACA5012 coordinates file (this should be on the same page/folder where you 
obtained this document)

● File → Import Geometry → Formatted point data (then select the file you just obtained) A good 
tip at this point is to go to File → Change Working Directory and change the directory to where 
you have stored the NACA data – this saves a lot of navigation through file dialogues later.  

● Then click apply in the bottom left corner of the screen

● You should have a screen that looks like Figure 2:

Figure 2: Point Input to icemcfd

● We then want to create a curve made of those points to describe the surface of aerofoil

● Under the Geometry tab in the top centre of the screen click on the Create/Modify Curve 
button

● This pops a new menu in the bottom left.  Click on the top left icon underneath “Inherit Part”, 
This is the “From Points” tool.  Click on “Inherit Part” to deselect it and name the part 
SUCTION.   

● You should then select each point on the top of the curve one after the other with the left 
mouse button.  (There ought to be a better way of doing this but I can't seem to find it!)  You 
might need to zoom in to get all the points in the trailing edge.  The middle mouse button 
accepts your final selection 

Hint: Pressing F9 suspends the Selection Mode and allows you to use the mouse to control the 
view, hitting F9 again puts you back into Selection Mode.

● Repeat the process for the points on the bottom of the curve.  Name this PRESSURE.  
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● Then we want to create the surface on which we will calculate the fluid flow.  To do this we will 
create a domain around 1 chord lengths above and below the aerofoil and 1.5 chord lengths 
before and after.  This is slightly arbitrary and we may want to change this after we look at the 
results!  

● Add points at (-1.5,1),(-1.5,-1),(2,1) and (2,-1)  Click on the Create Point tool under the geometry 
tab and use the Explicit Locations tool to do this.  

● Join these points together with straight lines. Label the left hand one INLET, the right hand line 
EXIT and the upper and lower parts TOP and BOTTOM.  Your screen should look like Figure 3.

Figure 3: Aerofoil and Calculation Domain.

● We are going to construct an outer surface called FLUID which will then mesh later.  

● Make a surface from the outer edges into surface (Geometry Tab → Create/Modify Surface → 
Simple Surface)

● Click on the “Inherit Part” button so that it is no longer checked

● Rename the Surface as FLUID

● Select the four curves

● Click on OK or Apply

● This surface might not actually be visible.  On the left hand side of the screen is tree menu 
that controls what is and is not visible.  If you want to see the surface simply go through the 
menu and ensure that under “Geometry” the “Surfaces” node is ticked.  

-3-



Durham University icemcfd Tutorial

Setting up the Initial Blocking

To do this we need to apply what is known as a “blocking strategy”.  In icemcfd for structured 
meshes the geometry is joined to a series of blocks which are then filled with the cells that make up 
the actual volumes on which the calculation will take place on.  The process of meshing is therefore 
somewhat different from the CAD programs you will have used up to now as you are not trying to 
draw the part but the surrounding area which the fluid surrounds.    

● Go to the Blocking Tab

● Click on “Create Block”  and ensure in the “Initalize Blocks” drop down the type is 2D Planar 
and the part selected is “FLUID”.  Click OK,  A blue message saying “Initialize blocking done” 
should appear in the message window

● This creates a Block which we then need to associate to various edges

● In the Blocking Tab click on “Associate” (fifth tool from the left) then in the left hand menu that 
appears select “Associate Edge to Curve”.  This should look a bit like Figure 4 , note that in 
Figure 4 the points are not displayed.  

● You now need to associate each side of the block one of the parts we made earlier.  (INLET, 
OUTLET, TOP and BOTTOM).  This must be done separately for each part.  To do this: 
Click on the first edge (which is part of the blocking) and then the first curve (which is 
geometry).  This is most easily done by left clicking and middle clicking - an on screen prompt 
guides as to which mouse button to press when.    
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Figure 4: Setting up the Blocking
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Hint: This is a part of the tutorial that confuses people a lot.  The edges (part of the blocking) 
and the curves (geometry) are actually on top of each other on the screen.  Although they are 
physically coincident on the screen there is no logical connection between them until you make 
one using the associate tool.    

● We can now get icemcfd to do a crude initial first mesh.  Go to the Mesh Tab → Part Mesh 
Setup and set the max size to be 0.1 on all the parts.  Then go to the Blocking Tab → Pre-Mesh 
Params (9th from left) select the “Recalculate Sizes” tool and click ok.  It may look like nothing 
has happened but a first mesh has been created!

● To see it you need to make the mesh viewable.  On the left hand side of the screen there is a tree 
menu with a white background.  Expand the Blocking Menu and click on “Pre-Mesh” a square 
mesh that completely ignores the aerofoil should now appear.  Clearly there is work to be done! 
You should now turn the Pre-Mesh view off to make manipulations easier.  

We now need to associate the face (the mesh) with the surface (the FLUID part we created earlier.

● On the Blocking Tab select the Associate Vertices icon (fifth from left).  In the tool that pops on 
the bottom left select  Associate Face → Surface (fourth from left).  Then select the face and the 
FLUID part in the pop up window.  
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Figure 5: The Pre-Mesh View turned on.
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Meshing the aerofoil

Clearly we need some way to tell icemcfd that we would like the mesh associated with the aerofoil 
shape in the middle of the screen and to organise this mesh so that we end up with the right sort of 
mesh.  

● First further divide up the Blocks.  Blocking Tab → Split Block and then select the Split Block 
tool.  Use this tool to split the block upstream and downstream of the aerofoil and above and 
below the trailing edge.  Again left and middle clicking is the most efficient method.  Your 
screen should look something like Figure 6

● Now we want to add a special type of block called an “Ogrid” around the aerofoil.  Go to the 
Blocking Tab → Split Block (Second from left) and then select the Ogrid Block tool (Second 
item from left in the bottom left panel).  After you have selected the tool you need to Click on 
Select Blocks.

● Select the central block and the block on the middle right by using the left mouse then the middle 
mouse and two turquoise squares should appear in the centre of your screen.  Now click on the 
Select Edge(s) option within the tool and then select the right hand most edge.  A yellow square 
should appear on the right hand side.  Click ok or apply to define a new O grid. 

● Now we should delete the central block as this is the aerofoil itself and not something that we 
actually want to calculate.  Blocking Tab → Delete Block and left click on the central square and 
use middle mouse to get rid of it.  Your screen should look something like Figure 7 whilst you 
are doing this.  
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Figure 6: Splitting the Original Block
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● Now we will merge four points together to clean up the trailing edge.  On the Blocking Tab 
select the Merge Vertices icon (third from left) and then select the two vertices that make up the 
left hand side of block 23 in Figure 7 and then do the same for the points on the right hand side. 
This collapses the block. 

● We then associated out block with the aerofoil points.   Blocking Tab → Associate, then use the 
second tool from the left to associate all three edges on the middle block to the curves 
(SUCTION and PRESSURE) that you defined earlier.  Ensure that the Project vertices option is 
selected and this will then snap the vertices to the edges.  

● After all this your mesh should look like Figure 8.

-7-

Figure 7: Deleting the Central Block
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Figure 8: Trailing Edge Block Eliminated

● On the left hand side of the screen there is that tree menu with a white background, if you click 
on Pre-Mesh you should be able to view the mesh again.   

● The mesh most likely still occupies the centre of the aerofoil, so we add a point to guide the 
program about where we would like the mesh to go.  Blocking Tab → Edit Edge, then select the 
Split Edge tool and select Linear from the drop down menu.  

● This should look like Figure 9.
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Figure 9: Setting up the Linear Point to Snap the Mesh to the Outside of the Aerofoil

● At this point you will want to adjust the position of the vertices on the aerofoil so that it gives a 
more reasonable mesh.  Blocking Tab → Move Vertex tool will accomplish this.  

● The Pre-Mesh Parameters tool (Blocking Tab → Pre-Mesh Parameters (Ninth from left) then the 
Edge Params Tool (Third from Left) should be used to add more points in various places. Until 
the mesh looks better.  

After some work and moving points around, along with changing the number of points, the mesh is 
shown in Figure 10.

-9-



Durham University icemcfd Tutorial

Figure 10: A First Attempt at the Mesh

● A number of tools allow you to assess the mesh quality.  Blocking Tab → Pre-Mesh Quality 
Histograms allow you to look at things like the worst element.  A graph appears in the bottom 
right which you can click on to examine the the worst element then adjust the mesh spacing, the 
position of the vertices on the blocks and so on.  

● For our mesh this looks like Figure 11.  

This isn't a great mesh and if you wanted to actually trust the results from it you'd need to do more 
work.
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Exporting the mesh

The final step here is to export the mesh.  The follow steps appear to work but might not be the 
optimum solution.  

● In the selection tree with a white background, expand the blocking option and then right click 
over the Pre-Mesh label.  A context sensitive menu will appear in which you should click 
“Convert to Unstruct Mesh”

● Go to the output tab and click on the left icon “Select Solver”.  In the Output Solver option 
which will appear on the bottom left select Fluent_V6.

● Again in the blocking tab select the right most icon “Write Input”.  After the file dialog a box 
will pop up asking you to edit Fluent V6 options make sure you make the Grid Dimension 2D 
and then click done.  Success is indicated by “Done with translation” in the message window.

You can then read this mesh into the solver program fluent 12 directly.  

Note the icemcfd has a multitude of options to improve the mesh which you are strongly 
encouraged to explore.  The above is simply to guide you through the process so that you can get a 
result quickly – refining and producing a good solution is up to you!  

Grant Ingram and Richard Williams

Thursday 20 October 2011
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Figure 11: Finding the Lowest Quality Elements


